Dienstag, 27. November 2012

rsAccessedDenied on Windows 8

rsAccessedDenied - The permissions granted to user 'mydomain\myAccount' are insufficient for performing this operation.(rsAccessDenied) (ReportingServicesLibrary)

Do you know this error?

I spent ~2 hours trying to fix it, only to find out in the end, that it was really easy.

I'm running Windows 8 and have SQL Server Express with Reporting Services installed and configured. So unless you have the same configuration the origin of your error might be different.

Anyway - after setting up everything and changing the website to port 8080 instead of the default port (80), because that one didn't work, I finally wanted to log on with my user but nothing seemed to work. For a friend on Windows 7 the solution was to start IE 9 with Administrator privileges, but unfortunately didn't work for me.

My user account is a local administrator so I figured it should have worked, but I am not THE local administrator.  The built-in administrator account.

And this one is disabled by default in Windows 8 so here is how you get it:

  1. Open good old Administrative Tools (you can find it via Start -> Search -> <search for it> -> Settings)
  2. Open good old Computer Management
  3. Computer Management (Local) -> System Tools -> Local Users and Groups -> Users
  4. Set a password for the Administrator
  5. Enable the Administrator

Now you can log on with Administrator and the password you have defined. 

I strongly define the necessary permissions for your normal user account and afterwards disable the Administrator account again.

Hope this saved you a lot of time :)

Donnerstag, 22. November 2012

Hyper-V error "IDE/ATAPI Account does not have sufficient privilege to open attachment..."


I have Microsoft Hyper-V running on my laptop (Windows 8). After the installation and configuration was a little bit of a pain (getting an internet connection wasn't that easy for me) it works very well.
Unfortunately I did another major mistake. I wanted to use my VM for classes for testing iptables, and still use it afterwards. But instead of making a snapshot, I did what I was used to do on VirtualBox - copied the file. And once I deleted the destroyed VM and copied my file back, I couldn't start the machine any more. The error displayed was:

"IDE/ATAPI Account does not have sufficient privilege to open attachment..."

I've found quite fast an article on MSDN (http://support.microsoft.com/kb/2249906/en-us?fr=1) but the fix just didn't work for me. What worked was simply remove the Hard Disc which has the "broken" VHD loaded, create a new Hard Disc and load the VHD there inside. Hyper-V will set all necessary permissions on it's own.